johnliang8
 ( 7.07% )
- ago
the layout has changed as below, anyone can help?

0
816
Solved
4 Replies

Reply

Bookmark

Sort
Cone8
 ( 21.52% )
- ago
#1
What scaling are you using for your monitor? 200%?
Are you still able to scroll?

Anyway, it looks like the scroll bar isn't properly placed in the control - maybe due to the scale setting. We'll see if there's a setting we can tweak.
0
johnliang8
 ( 7.07% )
- ago
#2
yes, the scroll function still work for me
please help to check, thanks
0
Glitch8
 ( 11.82% )
- ago
#3
This is clearly a Microsoft bug introduced in one of the recent updates. Something like this hit me recently too. When I disconnected my external monitor and ran WL7 on my laptop screen, it appeared compleltely shrunk down, like it couldn't adapt to the correct monitor settings. And the scrollbars looks grossly sized and badly rendered. I did an experimental compile to .NET 5 and strangely enough it resolved that issue. But we're not going to migrate to .NET 5, we're waiting for .NET 6 which should be released next month. But now, my issue seems to have resolved on its own maybe after another Windows update.
0
Glitch8
 ( 11.82% )
- ago
#4
After some research I found a solution to this that so far is working for me. Needs a bit more testing but hopefully we can include this in Build 29. It's a WPF bug that looks like it's already fixed in .NET 5 (it's not happening to me there).

https://github.com/dotnet/wpf/issues/334

Creating an app.manifest file for WL7 with the recommended section here resolved the problem at my end!
0
Best Answer

Reply

Bookmark

Sort