- ago
I'm looking to backtest on the TSX but the only way I see to add data is to add each name individually. Since this is a fairly large index, is there a way to search up an index and have it add the members automatically?
0
391
Solved
15 Replies

Reply

Bookmark

Sort
Cone8
 ( 26.99% )
- ago
#1
No (but there's always "a way").
For most countries, the major index components can be found in the World Indices group, however, it seems that we've missed Canada. I think Eugene has a bot that updates those. Eugene, what do you know about Canada?
0
Glitch8
 ( 9.56% )
- ago
#2
One way would be to use our Norgate Data extension and have a Norgate subscription.

0
- ago
#3
I don't have a Norgate subscription, but I have Bloomberg. Can use that to get the data?
0
Cone8
 ( 26.99% )
- ago
#4
We don't have a Bloomberg Extension, but it's possible to create one. If you sent us a Concierge Request with your requirements, we could let you know what could be done and give you an estimate for the job - https://wealth-lab.com/Support/Concierge

Otherwise, you may be able to use your Bloomberg to export data to ASCII and set up an ASCII DataSet in WealthLab to read it.
0
- ago
#5
Are there any plans to introduce Canadian indices in your world index group?
0
- ago
#6
We haven't missed Canada: my bot keeps a shadow copy of the TSX index up to date. It's just we're not exposing it to World Indices. Since there's demand, sure we can resurrect it for WL8 build 34.
1
Best Answer
- ago
#7
Great thank you!
1
- ago
#8
0
- ago
#9
Eugene, any idea when build 34 will be available?
0
- ago
#10
We're targeting tomorrow.
1
- ago
#11
Hi Eugene, I see that Canada was added in build 34, but it isn't showing up in my datasets when I open wealthlab.
0
- ago
#12
Hi,
It's found under the "World Indices" group, not "My DataSets".
0
- ago
#13

I don't see it in world indices
0
- ago
#14
This DataSet provider caches its classification groups for a week. What's happened is that you had started B33 after a break in usage and later updated to B35. Naturally, starting the old build has cached the data without the TSX. So for the next 7 days your World DataSets will not receive updates despite the build upgrade.

To reset the cache, from WL's File menu choose "Open WL user data folder", open WorldDataSets, delete WorldDataSets.xml and restart WL8.
1
- ago
#15
That worked, thanks so much!
0

Reply

Bookmark

Sort