- ago
I have strategies that require that SM return the correct bar count as is inputted in Settings. That is not the case for Weekly scale.

Take Daily scale for example. If I ask for the most recent 100 bars:


Then I get 100 daily bars:


But for Weekly scale this is not the case. If I ask for the most recent 100 bars:


Then I get 21 weekly bars:


If I ask for 100 Most Recent Weeks:


Then I get 54 weekly bars:


Please advise how to always get the requested number of bars regardless of scale.

0
192
Solved
14 Answers

Reply

Bookmark

Sort
- ago
#1
In my quick testing, 'Most Recent Weeks' set to 100 returned exactly 100 bars for each symbol of the DataSet.
0
Cone7
- ago
#2
The key here seems to be using a linked IQFeed DataSet.

I was able to duplicate the 21 bars returned for a 100-bar Weekly request. However, the 100-week, Weekly request gave me 100 bars.
0
- ago
#3
QUOTE:
I was able to duplicate the 21 bars returned for a 100-bar Weekly request.

I can duplicate it too even with Wealth-Data.
0
Cone7
- ago
#4
Yes, it's a problem for any provider whose Weekly+ requests are compressed by the Data Valet using Daily bars.

Fixed for Build 14.
0
- ago
#5
This issue is not resolved with build 14. With weekly scale asking for 100 most recent bars returns 55.




0
- ago
#6
I'm not able to reproduce this, I wonder what is different in our setups, maybe you can schedule a Zoom call with us (write zoom@wealth-lab.com?)

0
Cone7
- ago
#7
I can't duplicate it either. I think the clue is that last week, you got 54 bars. This week, you get 55. This tells me that Daily data cache is cut off. I'm not sure how that happens, but as a test:

1. open a Daily chart for one of the symbols, like TROW or CVX.
- make sure it's sourced by IQFeed
2. at the bottom of the chart, click the date control, select "All Data"
3. right click and reload the data.
4. configure the date control for 100 bars
5. switch to Weekly scale.

How many bars were loaded?

6. Same question if you load "100 Weeks"?
0
Cone7
- ago
#8
Something else that may affect this are the Data Preferences -


You should probably have "Always load All Data for Charts in Daily+ Scale" checked as shown. If you don't, that could explain why you had a cut-off history. I think we should remove that preference so that it's always "All Data" for Daily+.
0
- ago
#9
That preference does not cause abbreviated historical data files in daily scale.
0
Cone7
- ago
#10
Alright. What do you think of removing the preference anyway and making the other one exclusive to intraday charts, i.e., "Amount of Data to load in Intraday charts"?

Does anyone see reason to limit Daily+ data in charts by default? Otherwise limiting to the same range as intraday seems too restrictive, and you can always load precisely what you want later anyway.
0
- ago
#11
I hope you can follow below as I am really not set up to do testing. I have followed Cone's comments.





0
Cone7
- ago
#12
I don't know what's wrong with your cache, but it looks like your "All Data" for IQFeed starts on 8/6/2021 based on the chart test - that's right around 55 weeks ago. I'd just start over. (The last image with 7,441 bars is Wealth-Data, not IQFeed.)

If you want to conserve intraday data so you don't have to download it again, let me know. Otherwise, just do this and I'm sure everything will work -

Data Manager > Historical Providers > IQFeed - right click and "Delete Local Files".

0
Best Answer
- ago
#13
I will do this after hours and report back.
0
- ago
#14
That did it thanks.
1

Reply

Bookmark

Sort