- ago
If you open a saved block strategy, test it, close it and then test it again (with no changes in betwee n) you will get different results. This bug existed before, but has now been fixed. Now the error occurs again. The differences in the APR are, for example. at 1-2 percentage points. Transaction Weight is set. So results have to stay 100% the same.
Thanks!
0
672
6 Replies

Reply

Bookmark

Sort
- ago
#1
note: if you increase the margin factor to 1.1 oder 1.2 the differences become less. with margin factor 2 there are no longer any differences. nevertheless that shouldn't be the solution ...
0
- ago
#2
This is not a bug. Please read the FAQ > "Every time I run a Strategy I get a different result. Why?"
https://www.wealth-lab.com/Support/Faq
0
Cone8
 ( 23.73% )
- ago
#3
Since you mentioned that you were already Transaction Weights for trades, the other possibility is the randomness of executing Stop or Limit exit orders on bars in which both signals could trigger.

See the discussion here, but we didn't get to belly button until Post #18, where a solution is also proposed to assign a T.Weight for exit signals too. Specifically, a higher weight to pessimistically favor Stops.
https://www.wealth-lab.com/Discussion/Percent-equity-position-sizes-changing-from-day-to-day-7165
0
- ago
#4
@Cone: thanks - no stopps, no limits, no targets & just a simple time exit.
0
- ago
#5
Maybe you erroneously dropped the Weight condition on an exit Block.
0
Glitch8
 ( 14.35% )
- ago
#6
Please do give us a concrete, reproducable example of this. We'd love to help but it's just too vague. I spent some considerable time trying to reproduce your issue with Building Block Strategies, but when I add the Transaction Weight block I always get the same result. I can't spend any more time feeling around in the dark on this. Please share a complete Strategy, DataSet, Position Sizing settings that we can use to help.
0

Reply

Bookmark

Sort