- ago
I set my rotational strategy to 20% of equity. Right-clicked it in SM and selected Run Now. The signal it generates is for 100% equity. I deactivate it, select Configure, and look at the Position Size. It has been changed to 100% equity.


3
281
10 Replies

Reply

Bookmark

Sort
Cone8
 ( 21.52% )
- ago
#1
I can't make that happen.
That happens in the same WealthLab session without Workspaces being involved?

Hold on.. Is it possible that you're using a Rotation System that is set up for 1-symbol rotation? That would be 100% sizing.
0
- ago
#2
No workspaces involved. Same session.

I am doing a rotational strategy with 1 position. It’s a 8 symbol dataset but only buying/selling 1 symbol at a time. Can I not do that with 20% of my capital?
0
Glitch8
 ( 11.82% )
- ago
#3
Rotation systems are designed to automatically set the position size to a percent of equity based on the number of symbols selected to retain.

I can see your point about wanting to limit this for trading purposes. We might need to consider an enhancement to enable this.
0
- ago
#5
I thought it had been working the way I was suggesting, but I’ve never run a rotational strategy to auto-place so paid little attention to the position size. I’d love to run a couple of these to auto-place with a portion of my account’s capital…but def not all of it. I understand your point though.
0
Glitch8
 ( 11.82% )
- ago
#6
I added a #FeatureRequest tag so we can get the idea logged and tracked.
0
- ago
#7
Okay. I didn't realize WL8 users were just running one rotational strategy as the only strategy that they would be able to run for an individual account. Seems pretty risky! I guess the work-around for now is to open another account with another broker and have the rotational strategy solely use the equity for that new account.
0
- ago
#8
As a workaround, wouldn't a MetaStrategy, with that rotational strategy allocated 20% of the capital, work?
1
Glitch8
 ( 11.82% )
- ago
#9
Originally Rotation Strategies were meant to be manually traded, the idea was you would just need to enter a few orders every day, week, month, etc depending on the rebalance. How hard could that be?

Well due to user demand we recently enabled them for the Strategy Monitor so now we need to work through the real-world ramifications.
0
- ago
#10
I guess I'm having the same problem. I was trying to add Rotation Strategy to the Meta Strategy backtest. but I realized that the Position Size setting didn't work.

For example:I want to allocate 2% equity for 5 positions of Rotation Strategy, which is 10% of the whole account, but the system automatically adjusts it to 20% of the whole account. And it leads to incorrect backtest results.

So one more vote for this feature request.
1

Reply

Bookmark

Sort