- ago
Hi, I am having a problem setting up my strategy to go live on Binance, even though there should have been at least 50+ orders overnight, there have been none. The strategy used fixed cash amount. I then noticed that if I put position size to "fixed value", the order does not even go through. No errors, no orders, nothing. Yet if I put position size to shares/contracts, the orders go through normally.

Using wealthlab build 34 and binance build 21.

Could the problem be related to having a different currency other than USD? In this case, it's USDT and maybe the software does not recognize it.

1
611
Solved
29 Replies

Reply

Bookmark

Sort
- ago
#1
QUOTE:
Could the problem be related to having a different currency other than USD?

I guess so. Vote for Multi-Currency Support by clicking on the thumbs up button.
0
Cone8
 ( 23.73% )
- ago
#2
Actually the problem is that you [probably] don' t have the Use Fractional Shares option selected.

0
- ago
#3
Thank your answer Cone, but I do have that enabled :)



0
Cone8
 ( 23.73% )
- ago
#4
Okay, I just checked your the image that you posted in the starter topic - there is no Strategy attached to the Streaming chart.

Really, it works fine if you use a Strategy that generate Signals.
0
- ago
#5
This was the reason I even noticed the problem, I started a strategy (not on chart, but under "Strategy monitor", which generated signals, but never executed them, even though there were more than enough signals after checking history. The strategy used % of my equity, not shares.

Now I did not put that strategy on chart itself, but in either case live trading does not allow me to do two things:

- use fixed amount of cash for trades
- use % of equity for trades

yet I can use 0.01 of share for trade (for example, 0.01 share of bitcoin per trade).

Also, it kind of defeats the point to have to open up 10 charts to trade 10 crypto pairs if the only problem is not having live strategy on chart itself. Also, 0.01 share of 1 cryptocurrency is not the same as 0.01 share of other cryptocurrency.

The question is, have you successfully tried and replicated the same problem I have on Binance?
0
Cone8
 ( 23.73% )
- ago
#6
QUOTE:
which generated signals, but never executed them
If Signals were placed but not filled, then we're talking about something else altogether. Without any other evidence, it's probably the case that you just didn't enable the Auto-Place button after (or before) Activating the Strategy in the Strategy Monitor.

Again, if the Signals are there, but nothing's happening, it's a different problem - either the signals aren't Place, or, there's an error with the trade - in which case there will be more information about it in the Order Manager and/or Log Viewer (Ctrl + L).

Show us what actually happened, and we can usually explain it. As it stands now, you're making me guess what might have happened after revealing new information in a piecemeal way.
0
- ago
#7
When I order BTC USDT and put 0.01 btc share, the trade goes through just fine (in this case, it says I have insufficient balance).

https://gyazo.com/9c204f65cb72f6f1760b4b18a3711397

When I try to do the exact same thing with fixed amount of 50 usdt, or 100 usdt, or any usdt for that matter, not only does trade not execute, there is absolutely nothing in either log viewer, or order manager:

https://gyazo.com/dc7e2d658e73513f53b6d898c1918237

I seriously doubt I am the only one having this problem.
0
Cone8
 ( 23.73% )
- ago
#8
Thanks for the video. It clarifies where the "signals" (not signals) are coming from. You're using the chart "Tradable" buttons.

If you're trading less than $300 with BTC, you'll be the only to see it. The trade quantity precision is defaulting to 2 decimals. Therefore trade quantities below 0.01 (BTC) are rounded to zero, and that's why nothing's happening. We can investigate that!
1
- ago
#9
I see... thanks for clarifying :) I just noticed that you could be right, because I just tested out on another cryptocurrency pair - 1INCH / USDT - and 50 usdt and it managed to place the trade:

https://gyazo.com/aced0d2532ed14acd42bb9b64654317d

However, if I try to use 10% of equity option, it delivers a similar problem as the one with BTCUSDT, nothing in order manager or log viewer:

https://gyazo.com/a4aea78bb8bc47fd2567f87606b09f1a

maybe this could be correlated?
0
Glitch8
 ( 14.35% )
- ago
#10
By all means we’ll get this on the short list for a remedy!
1
Cone8
 ( 23.73% )
- ago
#11
FIxed for the next release (Binance Build 22).
1
- ago
#12
wow, that was fast :)

did you also include the 1INCHUSDT issue I provided?
0
Cone8
 ( 23.73% )
- ago
#13
Yes, the trade quantity decimals weren't always being assigned correctly, and that affects the rounding of trade quantities for the Position Sizing calculation.
1
- ago
#14
While the fixed amount of cash works for trading now, choosing "Percent of Equity" and trying to buy still gives me no order or anything in error log, at least not when trying to trade directly on grid. This would be crucial for me, as my strategy revolves around % of equity for trading because of strategy evolver.
0
Cone8
 ( 23.73% )
- ago
#15
Be specific. What symbol are you trading with what order type (and price if applicable) with how much % of equity in what size of account? And, what Preferences > Trading > Portfolio Sync options are checked?
0
- ago
#16



The symbol I am trying to trade on chart is BTCUSDT, with binance connected to my account. Above are my settings for trading, which shows that my account is synced to my portfolio value.

https://gyazo.com/b8f76ef6a813df6e7151710f46db3172

same problem arises if I try any different coin (1INCHUSDT):
https://gyazo.com/1a0db0502b2d4fcd874aa0632d357311

I have more than enough funds to test whether this works or not too, and neither of them are traded with different currency than USDT:

0
Cone8
 ( 23.73% )
- ago
#17
There's a problem with the "Account Value" - there is none.
Apart from the Listen Key and Connected messages, there are no other messages for Binance in the Log Viewer?

You can uncheck the "Use Broker-report Account Value", and enter your account value for Starting Capital in the Position Sizer, and it will work.

Apart from that, try shutting down Wealth-Lab, synchronizing your computer clock to internet time, and then check if an "Account Value" shows up in the Accounts tool.
0
- ago
#18
Unfortunately, none of the above worked, I have tried everything you said. There are no other logs besides those two.

The problem is most likely related to stablecoins not counting as "equity". However binance has multiple "equities" as there are multiple different stablecoins that are based on us dollar. In this case I simply want to use USDT for simplicity though.

Opening a fixed position trade with USDT works just fine though.
0
Cone8
 ( 23.73% )
- ago
#19
If you uncheck the Portfolio Sync "Use Broker-reported" option it certainly MUST work. But if you're going to do that , you might as well use Fixed $ size.

The issue is summarized here, which is a feature request.
https://www.wealth-lab.com/Discussion/Specify-base-currency-for-Binance-9346
1
- ago
#20
QUOTE:
If you uncheck the Portfolio Sync "Use Broker-reported" option it certainly MUST work. But if you're going to do that , you might as well use Fixed $ size.

The issue is summarized here, which is a feature request.
https://www.wealth-lab.com/Discussion/Specify-base-currency-for-Binance-9346


Hello, unfortunately this is not a convenient way to do it since I would constantly have to change my account size and could potentially miss on a lot of trades because of this.

I found out that on Kucoin, account size is shown and I can buy with %of equity which is excellent. Because of this, I will use KuCoin for now.

I noticed though, that BTC-USDT trades do not get filled when the order size is too small (The decimal error you fixed on Binance build 22). Can you make the same fix for KuCoin, so that I can buy 50 usdt worth of BTC for example? Nothing is seen in log viewer, or order manager.
0
Cone8
 ( 23.73% )
- ago
#21
KuCoin doesn't have the decimal problem that Binance had before Build 22.

Each crypto base asset has it's own minimum order size that you need to match or exceed. I'll check for BTC...
0
Cone8
 ( 23.73% )
- ago
#22
It's 0.00001 BTC, so you should be able to buy as little as 28 cents. Since I can activate an order at KuCoin for 0.00001 BTC-USDT, we'll have to figure out what's happening for you.
0
- ago
#23
What you stated above works just fine when placing a "manual order" under "order manager" with fixed size of "0.00001 BTC"



But it does not work when trying to buy 50 USDT worth of BTC, or 10% of equity of BTC (with my 500 USDT account) on Charts window


https://gyazo.com/569a65aae0a261a65fdb814d0b3aae81
https://gyazo.com/1a8fa3f004555a1d65745647b484d84f

I have "account value" this time.




This problem does not appear when buying other currencies with smaller Share price (example: 1EARTH-USDT). Found similar issues at ETH-USDT aswell.

https://gyazo.com/93480eaf99be5fc6e49feafe9b425fa1
0
Cone8
 ( 23.73% )
- ago
#24
Okay thanks. We'll investigate.
1
Cone8
 ( 23.73% )
- ago
#25
Okay, I see it. The KuCoin Broker Provider was using the right Quantity Decimals, but the Historical provider was putting the wrong value in the BarsHistory (which is used by the Backtester when calculating the sizing).

Fixed for the next Build (3).

I noticed the partial bar wasn't appear for Streaming charts, so that will be fixed too.
1
Best Answer
- ago
#26
Is the partial bar problem also related to "Cannot convert Scale to MuCoin kline interval"? Here I am trying to use streaming data while having a strategy activated to test it out live.



" at WealthLab.KuCoin.HistoryScaleExtensions.ToKlineInterval(HistoryScale scale)
at WealthLab.KuCoin.KuCoinHistorical.ResetTypeBridge(String param, HistoryScale cont, DateTime field, DateTime second2)
at WealthLab.KuCoin.KuCoinHistorical.GetHistoryInternal(String symbol, HistoryScale scale, DateTime startDate, DateTime endDate, Int32 maxBars)"



0
Cone8
 ( 23.73% )
- ago
#27
I don't know why the Data Valet is requesting those intervals from KuCoin, but we can take care of those "MuCoin" messages. In any case, you still should be getting a chart with the requested interval - it defaults to a smaller scale and compressed automatically.

The BarHistory's most-recent bar won't be initialized properly without the Partial Bar for the Strategy Monitor and Streaming Charts. For now, you can minimize the effect by Activating the S. Monitor just after the start of an interval.
0
- ago
#28
You are correct, the trading works just fine, so functionally-wise it's a non-issue, it just spams a lot of log messages :)
0
Cone8
 ( 23.73% )
- ago
#29
Decimals, Streaming, and messages fixed in KuCoin Build 3 - ready to install.

Make sure to update Binance and Kraken at the same time if you use those.
1

Reply

Bookmark

Sort