- ago
I am running a simple intraday backtest on dow 30 stocks, using among other things time indikators for entry and exit. This error message pops up and wl crashes. This machine is a virtual server.

When runnig the exact same strategy on a different pc (local machine), everything is fine.

Any idea what happens?

0
217
Solved
15 Replies

Reply

Bookmark

Sort
Cone8
 ( 21.52% )
- ago
#1
You need to upgrade your TWS and/or Wealth-Lab's IB Provider on your server.
One of those (or both) is far out-of-date.
0
Glitch8
 ( 11.82% )
- ago
#2
This is an unexpected input from IB, what symbol was this?
0
Cone8
 ( 21.52% )
- ago
#4
Okay, this an API setup error.
The IB Provider requires that you select operator timezone here.
Make this change in your TWS > Configuration > API and restart everything.

0
- ago
#5
Thanks for the tip. I'll have to try that first.

What I have found out so far is that there should be no problems if I keep to the following sequence:

a) start WL first
b) start TWS afterwards

Then every backtest works as usual.

However, if I start TWS first and WL afterwards, these crashes occur.
0
- ago
#6
Unfortunately, your suggestion, Cone, does not solve the problem. The crash continues to happen.

Regarding Glitch's question: it is a Dow30 portfolio of the data provider EODHD.
0
- ago
#7
I think I've found the problem. It is the EODHD intraday data.

If I run a strategy that actually works with daily WL data, everything works.

If I run the same strategy with EODHD end of day data, it also works.

But if I change this strategy to scaling 15 minutes, WL crashes.

But only if IB is connected to WL.

And only if WL is started after IB. (for this I am not 100% sure).
0
Cone8
 ( 21.52% )
- ago
#8
QUOTE:
Unfortunately, your suggestion, Cone, does not solve the problem. The crash continues to happen.
If you had "UTC format" selected previously, that was definitely the problem.
There's no doubt because the date format shown in the error uses IB's UTC format: yyyyMMdd-HHmmss.

To correct it, you must change that setting to operator timezone.
Apply it. Save it.
Close Wealth-Lab.
Close TWS.
It will work. But if it doesn't work for some other reason, I want to see the new error.
0
- ago
#9
I have changed the settings at IB and saved them. Crash nevertheless.



0
Glitch8
 ( 11.82% )
- ago
#10
That’s a different exception. It’s now caused by parsing a decimal number, not a DateTime.
0
- ago
#11
Still, what IB extension build are you running?
0
Glitch8
 ( 11.82% )
- ago
#12
So, changing the setting that Cone suggested looks like it fixed the DateTime parse issue. There's probably another setting that needs to change to fix this decimal parse. Let's see what the IB expert Cone has to say.
0
- ago
#13
@Eugene: all extensions & TWS are up to date.
0
Cone8
 ( 21.52% )
- ago
#14
This is an old long-standing IB bug for clients who use whitespaces for thousands separators.
It's in the IB API, so there's nothing we can do about that.

Solution:
Set up Windows to use a printable character as the thousands grouping separator. It might even have to be a comma or a period.
1
Best Answer
- ago
#15
Thank you Cone & Team. It seems to work.

if there are any further problems, I will get back to you in this post.
1

Reply

Bookmark

Sort