- ago
Using Wealth lab V44, IQFeed V16. Streaming provider is IQFeed, Historical Provider is IQFeed.
If I open a chart, the current day only displays the candle from the time the chart was opened, or when a different symbol was entered. If I include WealthData as one of the historical providers, I get the full candle for the current day for most, but not all, symbols.

Time frames that are less than daily, seem to show the full candle for the current bar, using only IQFeed for historical and streaming provider.

I don't notice the behavior in WealthLab 6.9.

Seems like something is wrong. Maybe I have some setting incorrect, but I can't find it, so I am listing this as Bug Report.
0
345
Solved
17 Answers

Reply

Bookmark

Sort
- ago
#1
Did you activate streaming in the chart?
0
- ago
#2
yes
0
Cone7
- ago
#3
It's not our experience. Can you show us? Here's what I'm seeing. Is it different for you?

0
Cone7
- ago
#4
And here's IQFeed -

0
- ago
#5


hopefully you can see the image......
I took a screen shot right after opening the symbol ATI
0
Cone7
- ago
#6
I see - it looks like it's missing the partial bar. Again, not our experience.



Check Tools > Home Page
Is everything up-to-date?

Also, make sure that your computer's local time is in accordance with the time zone selected. Very important!
0
- ago
#7
local time is correct.
All items in the version information are up to date.
I am using only IQFeed for streaming provider and historical provider.
I used the same chart that I used for daily data to display time frames less than daily, and got bars that were "full" back to the prior bar. For example, I checked a 15 minute time frame by opening the chart at 52 minutes after the hour. don't remember the exact time. Current bar was full back to the prior completed bar.
On Daily bars, if I use both IQFeed and WealthData as historical provider, I get complete daily bars for most, but not all symbols that I checked.

After market close, I get full bars on the current day using only IQFeed for streaming and historical provider.
0
Cone7
- ago
#8
To use the same terms, I think your "full bar" is actually what we call a "partial bar". A partial bar contains all the trading activity from the start of the bar, but it's only "partial" because the end of the interval has not yet occurred.

If I understand correctly, it sounds like you're having intermittent success getting the partial bar for Daily charts. We'll keep an eye on it. If there's a procedure you can define to make it happen, we could get to the bottom of it more quickly.
0
- ago
#9
Your Partial bar is what I am talking about when I say Full.
I have noticed similar behavior on weekly chart for the current day.

I don't see this on daily bars in wealthlab 6.9 using IQFeed.

When I update to a new version of Wealthlab 7, should I uninstall the prior version? I did not uninstall Version 43, before updating to version 44.

I have zero success on partial bars using only IQFeed for historical and streaming provider. I get partial success using IQFeed AND wealthdata for historical provider.
0
- ago
#10
No, you need not uninstall the prior version.
0
- ago
#11
I didn't think so. Thanks for the confirmation.
0
- ago
#12
Renamed the topic's title to reflect this:
QUOTE:
To use the same terms, I think your "full bar" is actually what we call a "partial bar".
0
Cone7
- ago
#13
QUOTE:
I have zero success on partial bars using only IQFeed for historical and streaming provider. I get partial success using IQFeed AND wealthdata for historical provider.
To be clear, WL7 history providers won't (shouldn't) display a partial bar unless you're viewing a streaming chart.

Right now, I don't have any clues why this isn't working for you. Can you try it on another machine?
0
- ago
#14
Yes, I am using streaming charts.

Last night I thought about this. I had a problem on streaming charts with BRK.B causing an error on Yahoo Finance to be displayed on the bottom of the chart. I looked at the data manager tab for historical providers, and turned off all of the historical providers except for IQFeed. I didn't think that should affect anything (silly me). So later in the day I turned on WealthData and got partial bars on some symbols but not all. One of those symbols was ARCB. Last night I looked at the symbols in the WealthData data set, and could not find ARCB. Based on that, I turned other historical providers back on in the Data Manager Historical Providers Tab, and set "BRRK.B=BRKB" in symbol mapping in the Streaming Providers tab.

Everything is back to normal today.

My use case For Wealthlab is primarily generating streaming charts that I use for day and swing trading. Backtesting plays a much lesser role. However I do use the LaguerreRSI to spot dips for me, and I run a backtest nightly as a screen that gives me a list of stocks to look at for trading tomorrow.

I am neither clever enough to generate a bullet proof trading strategy, nor a good enough programmer to implement such a strategy. Therefore, I am not about to let some strategy programmatically trade my account - I am clever enough to see that I would go broke in a hurry doing that!

Sorry for the false alarm, and thanks for your attention to my problem.
0
Best Answer
- ago
#15
QUOTE:
and set "BRRK.B=BRKB" in symbol mapping in the Streaming Providers tab.

Right on, and this feature is certainly good to have when the symbology varies so much among different vendors!

Thanks for sharing your use case. One can't go wrong with being cautious and sticking to his own plan.
0
Cone7
- ago
#16
Great, thanks for the news.

It's off-topic, but I'll just opine that its unnecessary to use full automation. You could Stage orders for setups/exits and then manually Place them after reviewing the orders. Just that can ease the trading workload a lot and help to avoid order placement errors.
0
- ago
#17
Thanks,
I'll look into that.
Again, sorry for sending you guys off on a wild goose chase, and thanks for your responsiveness.
1

Reply

Bookmark

Sort