- ago
Good morning.

I hired a VPS server to run the Wealth-Lab.
However, when starting the program, the message is displayed:

System.InvalidOperationException: Could not determine your hardware token. Please contact us at www.wealth-lab.com.
at WealthLab7.MainController..ctor()
at WealthLab7.MainController.CreateInstance()
at WealthLab7.App.OnStartup(StartupEventArgs e)
at System.Windows.Application.<.ctor>b__1_0(Object unused)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)




And I can't put my login and password.

How do I proceed?
0
987
Solved
28 Answers

Reply

Bookmark

Sort
- ago
#1
Hi Tiago,

I can see that Wealth-Lab 7 works correctly for you on your physical hardware. However, running Wealth-Lab in a virtualized environment such as your VPS server may conflict with the software protection system. Because WL7 cannot determine the hardware parameters of your VPS server, it will not work there.

Please try a different VPS vendor because it may work there. For the record, what provider is this and what kind of virtualization they offer?
0
- ago
#2
The VPS run host-passthrough kvm.
0
- ago
#3
Hello,
I also tried to run WL7 on a virtual server but got the same error message. I tried two different VPS vendors and also both Windows Server 2016 and 2019. Does anyone have useful hints or ideas to solve this issue?

Best Regards
Matthias
0
- ago
#4
Hi Matthias,

Could you give more information about the VPS servers?
0
- ago
#5
I was going to run one WL7 copy on some kind of VPS/VDS too. I'll wait for more details on this topic then.
0
- ago
#6
@Replikant_m
Should you decide, you're welcome to provide feedback though.
0
- ago
#7
Hi Eugene,

thanks for your reply. What kind of information do you need exactly?

This is the server:

0
- ago
#8
Matthias, not sure what's wrong with this configuration. Frankly, I have no clue how to troubleshoot this case.

But I can tell that other demo users and subscribers have success running WL7 installed at several hosters like 1+1, Azure or Amazon (for example) using several versions of Windows Server DataCenter. Maybe this helps you.
0
Best Answer
- ago
#9
Hi Eugene,

I tried 1+1 / Ionos now and, I don't know the reason, but it works.

Best Regards
Matthias
1
- ago
#10
Matthias, I'm glad to see you're up and running again!
0
- ago
#11
Sometimes this problem occurs if you install WLD on Virtual Machine, it means that your VM could not generate Unique Server ID.

for example how you can solve this problem if you are using Proxmox Hypervisor:

Simply edit following in your /etc/pve/qemu-server/{vmid}.conf :

CODE:
smbios1:uuid={keep-current-id},manufacturer={Any Value},product={Any Value},serial=0


We set it for example to
CODE:
smbios1:uuid={current-id},manufacturer=PROXMOX,product=MOTHERBOARD,serial=0
1
- ago
#12
Free trial of Wealth-Lab 7 is not allowed in any virtual machines, hypervisors, clouds (AWS, GCE etc). It's a prerogative of subscribers.
0
- ago
#13
Hi, I have just bought a license. How can I start WL7 on a virtual machine now? Is still get the same error message "Could not determine your hardware token" right after start.
0
Cone7
- ago
#14
Try Help > Download your license
0
- ago
#15
Thanks @Cone, I can start WL7 on a physical computer and there it's possible to download the license via Help > Download.
But how can I transfer the license to a WL7 that's running on a virtual machine? On the virtual machine each attempt to start WL7 ends up with "Could not determine your hardware token" and the startup hangs with a splash screen saying "Checking license ...".
0
- ago
#16
Wealth-Lab cannot be activated on a device for which the hardware token could not be determined. That means it: the hardware parameters cannot be identified. You cannot transfer a license onto it. On the other hand, many WL7 subscribers use it in a virtualized environment (including various clouds) so it's a rare issue of your virtual machine which 'refuses' to identify itself.
0
- ago
#17
What kind of VM is this?
0
- ago
#18
My VM runs on QNAP Virtualization Station.
0
- ago
#19
If you need to run WL7 in a virtual machine right away please try out a software alternative. Subscribers successfully do this with software solutions from Oracle, MS etc.
0
- ago
#20
Hi,

I want to use a WL7 installation on a VPS.

When I start I get the following error:
System.InvalidOperationException: Could not determine your hardware token. Please contact us at www.wealth-lab.com.
at WealthLab7.MainController..ctor()
at WealthLab7.MainController.CreateInstance()
at WealthLab7.App.MapSingleton()
at WealthLab7.App.OnStartup(StartupEventArgs e)
at System.Windows.Application.<.ctor>b__1_0(Object unused)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

I am sure it worked (earlier releases?).

I have a premium licence, am I allowed to install an instance on several machines?
Would be very handy to have one instance for development on my PC and one for autotrading on the VPS.

Best ,
Simon
0
- ago
#21
Simon, what kind of VPS are you installing WL7 in? The more details the better.

You can find an explanation in post #16 above. We have this on our list of issues to resolve but may need more info.
0
- ago
#22
Here are some System Infos. I replaced the Systemname with XXXXXXXX, but is a proper name. It looks like it is running on a KVM Hypervisor 2 (proxmox?). I am not sure the provider changed it but I remember they announced some changes in their infrastructure.

CODE:
[Systemübersicht] Element   Wert    Betriebsystemname   Microsoft Windows Server 2016 Datacenter    Version   10.0.14393 Build 14393    Weitere Betriebsystembeschreibung    Nicht verfügbar    Betriebsystemhersteller   Microsoft Corporation    Systemname   XXXXXXXX    Systemhersteller   QEMU    Systemmodell   Standard PC (i440FX + PIIX, 1996) Systemtyp   x64-basierter PC    System-SKU       Prozessor   Intel(R) Xeon(R) CPU E5-2630 v4 @ 2.20GHz, 2200 MHz, 4 Kern(e), 4 logische(r) Prozessor(en)    BIOS-Version/-Datum   SeaBIOS rel-1.12.1-0-ga5cab58e9a3f-prebuilt.qemu.org, 01.04.2014    SMBIOS-Version   2.8    Version des eingebetteten Controllers   255.255    BIOS-Modus   Vorgängerversion    Plattformrolle   Desktop    Sicherer Startzustand   Nicht unterstützt    PCR7-Konfiguration   Nicht verfügbar    Windows-Verzeichnis   C:\Windows    Systemverzeichnis   C:\Windows\system32    Startgerät   \Device\HarddiskVolume1    Gebietsschema   Germany    Hardwareabstraktionsebene   Version = "10.0.14393.3297"    Benutzername   Nicht verfügbar    Zeitzone   Mitteleuropäische Zeit    Installierter physischer Speicher (RAM)   8,00 GB    Gesamter physischer Speicher   8,00 GB    Verfügbarer physischer Speicher   5,58 GB    Gesamter virtueller Speicher   9,25 GB    Verfügbarer virtueller Speicher   6,64 GB    Größe der Auslagerungsdatei   1,25 GB    Auslagerungsdatei   C:\pagefile.sys    Device Guard – virtualisierungsbasierte Sicherheit   Nicht aktiviert    Es wurde ein Hypervisor erkannt. Features, die für Hyper-V erforderlich sind, werden nicht angezeigt.   


Systemname XXXXXXXX
Systemhersteller QEMU
Systemmodell Standard PC (i440FX + PIIX, 1996)


This is the provider: https://contabo.com/en/

Probably it is related to inandr's observation, but I cannot make changes on that level since it is a shared hosting plan.
1
- ago
#23
Let's see if we can improve this.
0
- ago
#24
@tfritzen @mlohmann @MichaHahn2 @tradersdelightsystems

Please give the latest build a try and see if it's remediated and you can activate it in your VPS.
0
- ago
#25
Hi and thanks for the effort!

I got this message now, with an error code: Licensing Error, Code: 0x0001
0
- ago
#26
Sorry to hear that. Your shared VPS "refuses" our effort to determine the hardware token. Unless you wish to upgrade your plan to have more control, we may be out of options. :/
0
- ago
#27
No problem, if not I can switch to Ionos, like mentioned in this thread. Thanks.

Another question, maybe a bit offtopic to this discussion:
On how many machines can I run WL7 with one licence?
0
- ago
#28
At your service. You can run WL7 on two devices simultaneously.
1

Reply

Bookmark

Sort