- ago
Have a chart with a strategy. After unchecking the chart toolbar it disappears and then at some point reapers. Thus having to keep right-clicking on the chart to uncheck the "Lock chart toolbars" option.

Way to make the toolbar reappear on the chart:
1. Enter a new ticker or change the chart's bar time (ex., from daily to 30-minutes)
2. Rotate the mouse wheel to change bar resolution.
As soon as I rotate the mouse wheel, the toolbar reappears.

Please make the setting stick, regardless of the above (and other) scenarios.

Using WL8 build 6.

Thank you.
0
203
Solved
7 Answers

Reply

Bookmark

Sort
Cone7
- ago
#1
It is already sticky. When deselected, it re-appears, by design...

1. when the pointer is within a toolbar's width of the top of the chart,
2. while you're entering a new chart symbol

Are you describing something else?

Edit - I don't see the behavior using the mouse wheel. Does the mouse wheel change the bar width for you when the pointer is over the chart area?
0
- ago
#2
Yes, the mouse wheel changes the bar zoom/width.

Well, I have to move the pointer to the top of the chart for the tools to pop so I can change the interval. So, yes the pointer is I guess in that area.

But that's not the desired functionality. If we hide the toolbars (to gain space) for the chart we should not have to keep hiding it each time we make changes to the chart. That's counterproductive and negates the setting.

Please make it sticky until we set it otherwise.
1
Cone7
- ago
#3
Maybe we're talking about 2 different things.

The selection is sticky. If you set it in a chart window, it won't change.

You may be fighting with the Chart preference. When you open a new chart, the preference for this setting (also sticky) is used initially.

Changing a selection on one chart won't change the preference for all new charts. Does that solve it?

0
- ago
#4
The key here is the chart must have a dropped Strategy. I was able to reproduce the issue and will work on this.
0
- ago
#5
I believe Cone's answer worked. I unchecked the "Always show toolbar" in preferences and it seems (from a quick test) to keep the toolbar off. I will update this thread otherwise.

Thank you!
0
Cone7
- ago
#6
Yes, I see it too with this combination:

1. The Chart Preference "Always Show Toolbar" - enabled
2. Dropped Strategy in chart window
3. Hide the toolbar
4. Change the scale and then scrolled the mouse wheel.

Hardly any set up required to duplicate that one. :P
0
- ago
#7
I have this fixed for Build 7.
2
Best Answer

Reply

Bookmark

Sort