- ago
I can no longer reconnect to Interactive Brokers after Trader Workstation automatically reboots overnight. It forces me to restart WL7 and rerun everything in strategy monitor. Has something changed with the interactive brokers extension?
0
384
10 Answers

Reply

Bookmark

Sort
Cone7
- ago
#1
Sure, it's changing a lot lately, and there's a lot more to come in Build 18.

IB's C# API doesn't report a disconnect as documented. I've got a ticket with IB on it that has been ignored. In any case, we'll keep looking on improving.

To work around TWS's forced restart, can't you schedule Wealth-Lab to restart at the same time? Or do this during the day when the session closes?
1
mjj37
- ago
#2
Thanks for responding Cone. Not much you can do if it is an API issue. I tend not to restart WL7 except for weekends. The Strategy Monitor takes about 1.5 hours to activate all my strategies at this point which is why restarting WL is such a pain.
0
- ago
#3
QUOTE:
On a separate question,

To continue with the separate question please visit this topic:
https://www.wealth-lab.com/Discussion/Why-does-the-SM-take-so-long-to-activate-my-strategies-7523
0
Cone7
- ago
#4
I'm doing all I can to make reconnection work following a TWS Restart, but at this point I can't say it's going to be reliable. :(

fyi,
IB Build 18 will have Streaming Bars. The main advantage is that the data will actually match historical bars, and, the processing footprint will be reduced since updates to the Streaming Bar occur only every 5 seconds.

Note that if you use IB Streaming, data are conflated (updated 250msec max for stocks). Consequently, you don't get the actual tick-by-tick updates that IB (or any other provider) uses to create the historical bars, resulting in minor differences in bar prices with respect to the historical bars.
1
- ago
#5
I am seeing a similar problem where I can't connect to IB this morning. (It was working yesterday.) I am getting the following error message in the Order manager when I try to connect.

QUOTE:
Connect to Interactive Brokers failed.


Auto Launch IB TWS is checked in data manager for both Historical and Streaming Providers.

I've tried every combination of restarting TWS and WL8. I then shut both down, started WL8 and it auto-started TWS. After successful login. I still got the above error message.

Please suggest what you think I should try to get connected.
0
Cone7
- ago
#6
Forget about Auto-Launch and Start TWS first and connection will always work.

Background -
Starting TWS takes a LONG time - nearly a minute on my machine. If connection fails because TWS isn't ready to accept a connection, you have to wait at least 30 seconds before trying again. Unfortunately, I think reconnection logic is fighting with this new rule imposed, so you might have to wait even longer. We'll try to make that more seamless in the future.
0
- ago
#7
I did what you prescribed but still can't connect. Sometimes the Connect button is green and sometimes it is greyed out (like now). I even restarted my computer.

I do get the following message if that is helpful in troubleshooting.

QUOTE:
Message Log - Use the green Connect button to connect to a Broker. You may need to Configure it first.
Market data farm connections OK: usbond, uscrypto, usfarm.nj, cashfarm, usfarm, ushmds, secdefil
0.5 seconds difference: Local - TWS time


Then I shut down TWS again, and waited a minute or two after login to launch WL* and try Connect. This time the button was green but got the original fail message.

No luck connecting so far this AM.
0
Cone7
- ago
#8
I certainly didn't prescribe shutting down TWS after connecting. Why would you do that?
0
- ago
#9
QUOTE:
I certainly didn't prescribe shutting down TWS after connecting. Why would you do that?

Well, I couldn't connect even after I followed your instructions, so I tried to start from scratch, thinking maybe IB had a flag set that thought it was connected (although WL8 did not.) Just trying everything I could think of to try to get connected.

This morning I have been able to connect. Not sure what was different about yesterday and today. Not aware of anything I did differently.
0
Cone7
- ago
#10
If there's a problem connecting, restart Wealth-Lab, not TWS. TWS needs to be ready to receive the connection. If TWS is ready and the API configurations are properly set up, it will connect every time, quickly.
0

Reply

Bookmark

Sort