- ago
I did not mark this as a bug because I'm not sure if this functionality is by design.

Here are the steps to recreate the (potential) issue:

Go to Preferences -> Trading and make sure that Enable Pre/Post Market Trading is checked.
Create or open an strategy that you use for intraday trading.
Go to the Strategy Settings tab and make sure you selected an intraday scale. I used one minute.
Uncheck Filter Pre/Post Market Data.
Save the strategy.
Open the Strategy Monitor.
Drag the above intraday strategy into the Strategy Monitor.
Filter Pre/Post Market Data is checked. It seems like it should not be checked, because when the strategy was saved Filter Pre/Post Market Data was not checked in the strategy's settings. Note that if the strategy has parameters they appear, and they seem to be correct.
0
84
Solved
1 Replies

Reply

Bookmark

Sort
Glitch8
 ( 12.33% )
- ago
#1
There are other things in the SM that don't adopt whatever was saved with the Strategy, such as data range. The thinking is that you often want to use different settings for live trading than in backtesting.
0
Best Answer

Reply

Bookmark

Sort