- ago
I had the idea to use Strategy Evolver to create a Strategy which enters with a market order.

So I disabled all Limit entries in Preferences->Evolver.

After a few Generations still the Limit systems took over because...

... at startup in slot 5 is a preconfigured DipBuyer with a limit entry :(

#FeatureRequest: Please let me change the "Preconfigured Strategies"

1
238
13 Replies

Reply

Bookmark

Sort
- ago
#1
I just discovered that I can go "Remove Strategy" in Evolver before I click Start.

This way I can remove all unwanted Limit-Entry strategies.

Cumbersome but working...

... and then:
It still chooses some Limit-Entry Genes in the next generations despite all are disabled! :(

How can I restrict Evolver to use At-Market-Entries only?
0
Glitch7
 ( 83.25% )
- ago
#2
I'm not seeing this, are you sure you disabled all of the Limit based Buy and Short genes?
0
- ago
#3
I have the same problem as Dr. Koch described... Thanks for solving the problem
0
Glitch7
 ( 83.25% )
- ago
#4
Sorry, I still can't even reproduce this!
0
- ago
#5
I used to check the "use filter sets" box. If I uncheck the box, then (so far) only the desired market entries will appear. Can it have anything to do with this?

By the way: sometimes the evolver does not continue and "get stuck" at generation nnn. are there any infos why this could happen?
0
Glitch7
 ( 83.25% )
- ago
#6
No, Filter Sets has nothing to do with this.

Even with Filter Sets selected, if I uncheck all of the Limit Entry Genes, then I never get any Strategies evolved using Limit orders.
0
- ago
#7
QUOTE:
Sorry, I still can't even reproduce this!


It took me a few days to find a simple way to produce this error.

* I did a fresh install of WL8
* Installed Powerback (not sure if this is relevant)
* removed all User Settings (removed User Data Folder)

here is the sequence:

* Select all genes in Evolver->Preferences (This is the default after a fresh install)
* Run Evolver for a few generations
* Disable all entries but "Buy at Market" in Evolver->Preferences
* Double check that all entries are disabled, only "Buy at Market" is active
* Close WL (not sure if Close/Restart makes a difference)
* restart WL
* Open Evolver
* some of the strategies contain genes which are disabled (this is already unexpected behaviour)
* Remove all strategies with entries other than "Buy at Market"
* Run Evolver
* Stop after a few generations
* There are strategies with entries other than "Buy at Market"



Due to the random character of evolver it might be necessary to repeat the sequence several times. Also not sure if a "Stop/Resume" makes any difference.

The critical part seems to be:
1.) run with all Genes
2.) run with restricted set of genes

Sometimes WL even "hangs" after this sequence.
0
- ago
#8
Same issue with WL8 B26. First time I've used the genetic evolver and immediately disabled several order types. Although, orders like "Buy Limit" or "Sell at Market Close" are still used. I guess there's something not properly taken into account...

0
Glitch7
 ( 83.25% )
- ago
#9
The reason these orders will still be used is because one of the preconfigured strategies uses limit orders. Just delete the strategy in slot 5 i believe before starting the run.
2
- ago
#10
I see, so the Evolver settings only apply from strategy 10 upwards.

0
Glitch7
 ( 83.25% )
- ago
#11
Right, they only determine which new things will be randomly generated and mutated.
1
- ago
#12
QUOTE:
It still chooses some Limit-Entry Genes in the next generations despite all are disabled! :(


I see this problem still in Build 28.

Evolver does not respect the settings in Preferences->Evolver->Gene Roster
0
Glitch7
 ( 83.25% )
- ago
#13
I’m still unable to duplicate this. can you write us at support@wealth-lab.com so we can schedule a zoom call and see your workflow?
0

Reply

Bookmark

Sort