- ago
I have connected my IBKR to Wealth Lab and everything shows up fine. I can push orders and get streaming data normally.
I have set up IBKR as a historical data provider and I can successfully get 5min chart data as below:


However, when I switch the time frame to 5min in the chart, it will only show data for the last hour( 12 * 5min bars) of everyday.


I'm not sure if there is an issue with the settings somewhere, please advise,thanks!

0
124
Solved
4 Replies

Reply

Bookmark

Sort
- ago
#1
You cut the status bar off when taking the screenshot. The one that shows the Market and Filter Pre/Post state. That's pretty important to know in the context.
0
- ago
#2
Hi Eugene,

Here's the updated screenshot. I tried switching the Filter Pre/Post state.
But the charts all start at 3pm everyday.



0
Cone8
 ( 24.80% )
- ago
#3
You probably missed a step in the TWS Configuration instructions... this one:

Send instrument-specific attributes for dual-mode API client in operator timezone..

After you change it, you should delete all the IB data you've already downloaded because the timestamps in the cache will be wrong. To do it, go to Data Mgr > Historical Providers, right click Interactive Brokers > Delete Local Files.
1
Best Answer
- ago
#4
Thanks Cone,

I think that's it.I updated the settings restarted the software and changed a ticker symbol and it went back to normal.

And yes, as you said, I need to delete the old data.
0

Reply

Bookmark

Sort