- ago
Hi,

I just installed B42 and now I cannot start the application.
I check the Windows' Event Viewer and am getting two exceptions:

From the .NET Runtime:
CODE:
Application: WealthLab7.exe CoreCLR Version: 4.700.21.56803 .NET Core Version: 3.1.22 Description: The process was terminated due to an unhandled exception. Exception Info: System.TypeInitializationException: The type initializer for '††† †††™“' threw an exception. ---> System.MissingMethodException: Method not found: 'Void WealthLab.Core.DataSet.set_Glyph(System.Drawing.Bitmap)'. at ††† †††œ.††† †††›.††† †††Ž‘(RuntimeTypeHandle ) at ††† †††™“..cctor() --- End of inner exception stack trace --- at WealthLab.DataExtensions.ScannerProvider.††† †††Š‘™(Object , DoWorkEventArgs ) at System.Threading.Tasks.Task.<>c.<ThrowAsync>b__139_1(Object state) at System.Threading.QueueUserWorkItemCallback.<>c.<.cctor>b__6_0(QueueUserWorkItemCallback quwi) at System.Threading.ExecutionContext.RunForThreadPoolUnsafe[TState](ExecutionContext executionContext, Action`1 callback, TState& state) at System.Threading.QueueUserWorkItemCallback.Execute() at System.Threading.ThreadPoolWorkQueue.Dispatch() at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()


And from the application:
CODE:
Faulting application name: WealthLab7.exe, version: 7.0.42.0, time stamp: 0x5f3ed523 Faulting module name: KERNELBASE.dll, version: 10.0.22000.348, time stamp: 0x065c557a Exception code: 0xe0434352 Fault offset: 0x000000000004478c Faulting process ID: 0x12ec Faulting application start time: 0x01d7f6839db5355c Faulting application path: C:\Program Files\Quantacula, LLC\Wealth-Lab 7\WealthLab7.exe Faulting module path: C:\Windows\System32\KERNELBASE.dll Report ID: dbcb2088-9252-4fe5-bba6-9bcf4492d7ba Faulting package full name: Faulting package-relative application ID:



I already tried to reinstall it, with the Repair option, but didn't work either.
Any suggestion, before I try to remove it and re-install it?

Thank you!
0
1,028
Solved
6 Replies

Reply

Bookmark

Sort
Glitch8
 ( 7.81% )
- ago
#1
You need to make sure all your Extensions are updated first. In this case, especially DataExtensions. I did post a warning in the Change Log about this.
0
Best Answer
- ago
#2
There is a breaking change. In particular, try updating the DataExtensions first (as per the exception source).
0
- ago
#3
Thank you Glitch and Eugene. That worked!

I was going to check the list of outdated extensions, from within Wealth-Lab, before downloading and installing them. Since that was not possible, I then downloaded them all and re-installed them quickly.
2
- ago
#4
I too just updated to 46 and it will not open. Read your post in discussions about updating extensions, but ... how do I update the extensions if I (A) dont remember which extensions I have already downloaded, and (B) how does one update the extensions if one cannot open the software to do so?

Sam
0
- ago
#5
Decided to just redownload all of the extensions and that did the trick!
0
Glitch8
 ( 7.81% )
- ago
#6
You can update the extensions right here from the web site, you don’t need to have WL7 open. I would try updating DataExtensions as that’s the one that’s known to cause the issue. Just click the Extensions link here on the web site and let me know if you are still having issues after the update.
0

Reply

Bookmark

Sort