- ago
Windows 11, x64.

WL settings


IBKR settings (latest)


IB API installed.

It connects with Order Manager, here is the log:
Now connected to Broker: Interactive Brokers.
Market data farm connections OK: eufarm, usfarm, euhmds, ushmds.nj, ushmds, secdefeu
1,5 seconds difference: Local - TWS time


After ANY attempt to receive market data it hangs with an exception which I cannot catch to copy. Something like "Input string was in not correct format"...

What I'm doing wrong?
0
167
5 Answers

Reply

Bookmark

Sort
- ago
#1
Hi Max,

Sorry you're having trouble with the IB provider. We suspect it may have something to do with an unexpected input due to parsing some numeric value.

1. Can you tell us what regional settings is your Windows configured with?
2. What are the decimal and currency separators in Control Panel > Region > Additional Settings > "Numbers" and "Currency" tabs?
0
- ago
#2
Hi Eugene,

I have Win11 with the following regional settings


Numbers


Currency
0
- ago
#3
Thanks. What if you change the Decimal symbol from ',' (comma) to '.' (dot) on both Numbers and Currency tabs? Give it a try and restart WL8.

P.S. No need to change the Currency symbol - just the two Decimals.
0
- ago
#4
Now it works. Thank you!
1
Cone7
- ago
#5
You shouldn't have had to make that change, so we'll look into where the issue could be.

Note - you have "Read only API" configured in the TWS API settings. Uncheck that if you intend to place orders with Wealth-Lab.
0

Reply

Bookmark

Sort