- ago
Using Build9.

Backtests in WL8 are *significantly* slower than in WL7. While undoubtedly there have been changes to the code base one contributing factor seems to be that WL8 is not respecting the Offline Mode option.

I did a simple test using one of my (simpler) strategies that runs on a dataset of approx 150 symbols. The strategy/ dataset/ backtest settings, etc. were identical in both WL7 & WL8. The option to use 'Offline Mode' was checked in both.

Here's the data usage statistics for WL7 after the backtest (virtually all of it is the initial handshake when the program is started):


And the same for WL8:


Hope the developers will fix this soon.
0
181
3 Answers

Reply

Bookmark

Sort
- ago
#1
Have you checked Event providers? They contribute a lot to the backtest speed. Especially the "Chart Patterns" - which is offline and CPU intensive.

P.S. As data may be re-downloaded on update when WL detects a refresh is needed (see Preferences > Data), traffic is not something that concerns me.
0
- ago
#2
But Sammy is concerned that this bandwidth was happening even when Offline Mode was turned on. Thanks for reporting, Sammy, the developers will fix the bug as soon as possible.
1
- ago
#3
Thanks, Glitch!
0

Reply

Bookmark

Sort