- ago
I would like to refine a daytrading strategy in the block [Short at Market].

The strategy runs as desired, but only if I disable this block:
[Close is greater than or equal to VWAP(Bars)*0.98 of 1 bar ago]
(German locale in screenshot: 0,98.)

I want to prevent short entries when the price is already too far away from the VWAP.

Then the error message appears: "Backtest Error: No Executor".

Exiting and reloading the strategy did not help. Platform: WL8 Build 3.

Backtest OK:


Error with enabled block:


MathIndOpValue Settings:


0
207
Solved
2 Answers

Reply

Bookmark

Sort
- ago
#1
This is fixed in build 4 - to be released later today.

Among other affected indicators are TradingDaysSince / TradingDaysLeft, USTYield, MathIndOpValue / MathIndOpInd, and the Candlesticks extension.
1
Best Answer
- ago
#2
I can confirm - it works in build 4.

At first the same error appeared.
The solution: I had to remove the block first and then rebuild it.

Thanks!
1

Reply

Bookmark

Sort