Unable to get Data on Demand: Could not create secure SSL/TLS secure channel
Author: instarac
Creation Date: 5/20/2020 5:54 PM
profile picture

instarac

#1
I am trying to run a multi-symbol strategy using daily data with Fidelity as the data provider. This is the error message:

"The request was aborted: Could not create secure SSL/TLS secure channel. Unable to get Data on Demand."

I am running Windows 10 on a Dell desktop with 4GB of RAM memory

Any one know anything about this?
profile picture

superticker

#2
QUOTE:
Could not create secure SSL/TLS secure channel.
This sounds like a problem with your Windows OS configuration. Check the error log from your Windows firewall for error messages. Take note of which network port numbers are involved. Are you behind a second firewall provided by your ISP? Have you tried running WL from another ISP (like the public library or Internet cafe)?

Wealth-Lab does not control network security on your computer. The OS, your router, and your ISP are in charge of network security for your system.
profile picture

Eugene

#3
There could in fact be many reasons for this error message, like incorrect PC clock (likely) or system registry misconfiguration or even a problem with Fidelity server's SSL certificate (that's unlikely).

I'd suggest you turn on demand update off, update your DataSet the normal way, and keep it up to date.

P.S. You said this is a multi-symbol strategy. In case it's a Streaming strategy, note that accessing external symbols doesn't guarantee that they get updated because on-demand request for the external symbol(s) may fail as the data is not yet up to date on the Fidelity side. The recommended workaround for Streaming strategies is to add a delay at the beginning of the Strategy. More info here: Choosing optimal trading tool: Strategy Monitor or Strategy window

profile picture

instarac

#4
Eugene, I'm a newbie. How do I turn demand update off and then update the DataSet the normal way?
I've always used the data on demand.
BTW, I am not using streaming data. My multi-symbol backtests always have a data range ending on the last complete trading day.
profile picture

Eugene

#5
I thought you knew it as your first forum post occurred 4 years ago. You'll find the answer in the User Guide (Help menu) > Data > Data Manager > Update Data.
profile picture

superticker

#6
QUOTE:
How do I turn demand update off and then update the DataSet the normal way?
Uncheck the "On Demand Data Updates" check box on the Update tab for Data Manager. But to update the static data (which you haven't done), you'll also need to go to the Update tab in Data Manager. The manual tells you how. I would update the static data after 5AM ET when it's stable.

In practice, you need both static and on-demand enabled because your static cache holds the Daily bars, but if you want to switch briefly to say 10-minute bars, then you'll need on-demand to download those. Working both together (static and on-demand) should be your goal.

Use Window's "Event Viewer" to determine from the Windows security logs exactly why your machine is refusing SSL/TLS connections. Don't guess; that will get you nowhere. And we can't help you if you can't tell us what the Windows event security error log says.
profile picture

Eugene

#7
QUOTE:
I would update the static data after 5AM ET when it's stable.

Good point, and the manual also tells how to automate the daily data update by scheduling it.

@instarac
And in the first place, reboot your PC. There's a chance it's just a glitch.
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).