- ago
Steps to recreate:

For the following use a strategy that has at least one equity with preferred values. On the strategy settings tab, observe the Use Prefered Values setting.
Open the Strategy Monitor.
Drag the aforementioned strategy into the strategy monitor.
Select a data set, etc. How the data set overlaps with preferred values does not seem to matter.
Observe the PV strategy parameter setting.
OK the Strategy Monitor - Strategy Settings dialog.
In the Strategy Monitor, click the aforementioned strategy and click the Configure button.
Change the PV checkbox setting and OK the dialog.
Click the Configure button again. The PV checkbox setting was not retained.

If you remove the strategy from the strategy monitor, go to the strategy and change its "use preferred values" setting and save the strategy, then if you repeat the above you'll find that the PV value in the Strategy Monitor settings reflects the setting of the strategy.

Hence, it seems either the Strategy Monitor Settings PV checkbox should be disabled if the strategy has preferred values (and the PV checkbox is to reflect that), or the PV checkbox should be enabled and retain its setting when edited.

WL 8 build is 16.
0
44
Solved
2 Answers

Reply

Bookmark

Sort
Cone7
- ago
#1
Okay, thanks for the details. We've got it logged for investigation.
0
Cone7
- ago
#2
Glitch has this resolved for Build 17. Thanks for reporting!
1
Best Answer

Reply

Bookmark

Sort