- ago
If you have the "Optimization Complete" sound enabled, and you put your computer to sleep, and then awaken it, the optimization sound complete no longer occurs. The "New Bar in Streaming Chart" sound works after the computer is awakened. So, the problem seems to be isolated to the "Optimization Complete" sound.

Workaround: close and restart Wealth Lab 8.

Additional info: other apps that produce sound work A-OK after computer is awakened from sleep. For example, Pandora running in a browser and small app I wrote that notifies me of regular time events. Also, disabling/re-enabling the audio driver doesn't make any difference.

The problem is pretty minor, but I thought I should report it.

System info:
Wealth Lab 8 build is 27.
Using Windows 11 with all drivers up-to-date.
Sound driver is Realtek USB Audio (version 6.3.9600.2306) and is Realtek USB Audio is set as the default audio device.
0
122
Solved
8 Replies

Reply

Bookmark

Sort
- ago
#1
I have the same hardware/OS setup and also have sound issues: the new Signal sound never works for some reason (I’ve tried to mute/unmute several times); as far as I can see all other sounds work well - and if I open the folder containing the files, I can play them without issue. This has been the case since a long time for me; and it’s not because of the sleeping in my case (my PC is always on).
0
Glitch7
 ( 83.25% )
- ago
#2
You can always try pointing them to different sound files, even custom ones. We’re not doing anything fancy playing these sounds, just using the basic classes provided by the WPF framework.
0
- ago
#3
To be honest, this was not so important to me, so I never really got to analyse it. But now that's being discussed: I just did a few tests and apparently it works for the sounds in WAV format, but not for the ones in MP3 format.

Going to do some more digging to check if it might have something to do with the file associations from some Media Player that I might have installed.

EDIT: Done the above (including resetting all file associations) without success.
0
- ago
#4
So, I just converted the 3 .MP3 files included with the WL8 installation, into .WAV; and then adapted the Sound Preferences accordingly. The problem is now gone!

If Paul1986 would confirm the same (you may convert the files with any mp3 to wav online converter); then I would suggest to change all sound files to .WAV in a future build, in order to avoid these glitches (they are probably related to some driver, but it's easy to fix like this, than to try to troubleshoot it).
1
Best Answer
- ago
#5
Nice find! Thanks.
0
- ago
#6
I tried alkimist's suggestion and used a wav file instead of mp3. The problem went away by using the wav file. I changed the configuration between mp3 and wav several times, sleeping and awakening. The mp3 always failed, and the wav always succeeded. Hence, this looks like a Realtek audio driver problem.
0
Glitch7
 ( 83.25% )
- ago
#7
We are converting all the built-in sounds to WAV for the next release.
0
- ago
#8
Before updating to the latest build 28, I deleted the Sounds folder (mine already contained some Sounds converted by me).

After the upgrade, it was again populated with all the sounds now in WAV format. As expected, the problem is now gone.

Thank you!
1

Reply

Bookmark

Sort