In SM, Strategy shows 0 alerts while 8 appear in the Alerts pane
Author: mtowle
Creation Date: 12/6/2017 6:13 PM
profile picture

mtowle

#1
Here is a screenshot of the results in SM. The strategy says there are 0 alerts, however, 8 appeared in the alert panel. Why is that?

I want to be able to eventually run multiple strategies and just look at top panel to know if I have alerts for any strategies. Right now I have to go through all strategies to find out if there are alerts.

Is there something I'm not understanding or is this a bug?

I just noticed in the same strategy that has not been stopped that it is reporting the correct number of alerts in the top pane so if this is a bug then maybe it happens the FIRST time a strategy is ran after activating it.
profile picture

Eugene

#2
QUOTE:
Here is a screenshot of the results in SM. The strategy says there are 0 alerts, however, 8 appeared in the alert panel. Why is that?

Right, 0 alerts for 12:03 PM, 2:00 PM etc. But the alerts in question are past alerts. In some (distant) past there was a build that didn't retain past alerts.

For a programmer this logic of wiping out the historical alerts (which is an oxymoron) is sensible but to many traders it wasn't so the change got removed:

Strategy Monitor in 6.4 not retaining Alerts + Run Strategy now De-activates the strategy

QUOTE:
I want to be able to eventually run multiple strategies and just look at top panel to know if I have alerts for any strategies. Right now I have to go through all strategies to find out if there are alerts.

Click "Show alerts for all strategies".
profile picture

Cone

#3
I'm getting old, but I don't recall that "stale" alerts were ever displayed intentionally. I see the change from 6.4 that deactivated strategies after "Run Now", but not one to display stale alerts. (Actually, the conversation you linked indicated that that behavior existed before 6.4, but was changed to not display old Alerts.)

Programmer or not, it just doesn't make sense to display Alerts from an interval that isn't from the last run. The image in the starter post looks wrong to me too - there are Alerts in the lower pane from 11:57, but the selected strategy in the upper pane indicated the last run was 2 intervals later at 12:03, and there are 0 Alerts.
profile picture

Eugene

#4
QUOTE:
The image in the starter post looks wrong to me too

I think this might be the result of logging out of Fidelity while SM is running (as discussed in a ticket). Mike?
profile picture

mtowle

#5
I'll see if I can reproduce this without logging out and back in. I don't think this was a log out/in issue. It might have been a disable / re-enable strategy issue. Regardless I'll check on both situations.